Adding Collabora to NextCloud

Hi All,

I’m trying to add Collabora to NextCloud. I followed the instructions located at
However, when I click on a file I receive an error:
Internal Server Error
The server encountered an internal error and was unable to complete your request.

Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.
Technical details
Remote Address: IPADDRESS
Request ID: 4fHPUfEYhvRhTRKToWgo

I checked the Nginx log at it shows:
2018/01/17 13:52:02 [error] 5265#0: *76 no live upstreams while connecting to upstream, client: MYSERVERIP, server:, request: “GET /hosting/discovery HTTP/1.1”, upstream: “https://localhost/hosting/discovery”, host: “

Any help would be greatly appreciated!

Is the docker container running?

Yep, docker container is running. Stoped and removed it. Even deleted the collabora/code image and reinstalled it. Then uninstall and reinstalled it. I have tried everything I can think of. I’ve been working and coding for two decades now and nothing I could try could get it to work.

Finally, I spun up another server and placed only docker and nginx on it. Pointed the domain for collabora at the new server and lord and behold it worked. For whatever reason it just does not like being on the same box as Mail-In-the-Box.

The only thing I can think of is that maybe the server doesn’t have enough power. It’s a VPS with 1gb of ram. Other thank that I have no idea.

But thank you for trying to help. I really appreciate it!