Activesync z-push not working

I installed 0.13 on 3 VM’s and found the activesync to be producing errors. Most clients stated “could not connect to server” after a lot of digging I fond the answer and am posting it here so that it helps other.

owncloud only allows connections from localhost by default. This causes the z-push combined backend using your box’s address to fail when it comes to Cardav/caldav. To make activesync work

edit the file /home/user-data/owncloud/config.php and add your domain to

'trusted_domains' => array(''),

This should get z-push working!

1 Like

That should already be in config.php.

buy default only localhost is added to that line. your boxes FDQN must be added manually for z-push to work.

No it should be whatever FDQN you entered when you set up your box:

That is strange. The actual file reads

array (
    0 => 'localhost',

Did this on 2 saperate installs. Also accessing yeilds

You are accessing the server from an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the "trusted_domain" setting in config/config.php. An example configuration is provided in config/config.sample.php.	
Depending on your configuration, as an administrator you might also be able to use the button below to trust this domain.	

Add "" as trusted domain

That is from a fresh install.

i must also point out /mail /admin workfine.

1 Like

Thanks for posting this. Looks like the new ownCloud 8.1.1 in Mail-in-a-Box v0.13a isn’t doing setup the same way and is resetting this setting. So no new boxes were getting set up correctly. I should have caught this in testing (and ownCloud should have documented this change!).

I’ve committed a fix and also released this fix as v0.13b. If you do the usual upgrade steps, your ownCloud should start working.

1 Like

This topic was automatically closed after 61 days. New replies are no longer allowed.