Access problems within LAN

Hello everyone.
I am bit dazzled: I can acces my miab from almos every computer. Except my son’s and my wife’s. They both run windows 10 on their laptos. Even though if I ping my domain I get a response, whichi I understand proves that the connection to the domain works (correct me if I’m wrong - glad to learn more). But when I try acces my mail account form the browser (firefox or opera), I get nothin. Err_timed_out or just “the sites didn’t answer” or something like that.
From my mac, form my iPhone, from Ubuntu 21.04 at work I have no problem accesing my miab (which, by the way is simply fantastic! - needed to say that).
I cleared the cache in firefox, the cookies, I even est the google DNS in TCP/IP ipv4 in Windows connection properties. Still cannot acces.
Anyone willing to help me out with this “issue”. Thanks in advance for your help, and congratualtions to the team that created mail in a box. I find it fantastic.
Thanks again.

I assume that your mac is on the same network (LAN) as your son and wife’s ? So that throws a wrench in the works.

If not for that ONE thing I would suggest that either your ISP or your router has some type of block in place.

Yes, my mac is on the same network (as a matter if fact is the “brains and muscle” I work with on the laptop with miab and the raspberry pi (using ssh). Sorry for not being more explicit before.
What really keeps me intrigued is: why am I able to acces the miab (my domain, for that fact) from any other computer, inside/oustine my lan, via WAN, and specifically these two computers give me error. That I really don’t understand. I tried form work, form different computers and OS (linux and windows), and had no problem. So, why is this happening? Should I “enable” them somehow in the ufw, or the problem radicates somewhere else (I doubt, even though I might be wrong, that my ISP or router have anything to do with this issue - because any other pages I try to acces I get no error, please correct me if I am wrong).
So, the bing “enigma” for me is this.
Thanks for answering though. I appreciate your help and thoughts.

Sadly, I am not much of a networking guy. That said …

So your MiaB is located on a RaspPi on your local LAN? And you got it to work? Kudo’s to you. :slight_smile:

Check your firewalls, access rules, etc … something has the connection blocked. Unfortunately, I haven’t a clue what …

Noooo ,my miab is on an olt Toshiba Tecra, running ubuntu 18.04. But through my mac, using ssh I manage both: the raspi and the Toshiba (wish I was able to make it running on a raspi… but I am not that smart, nor that fantastic programmer - I am just an amateur who loves tinkering, learning and learning more and more linux).
Thanks for the tip, though, I will pay a look at firewall and access rules. And also to the syslog, maybe I’ll find something helpfull there (helpful for the topic maybe).
Seriously, thanks for the help. It means a lot.

If you are able to access from outside your LAN then NAT traversal is working. So it seems likely to be a LAN side problem. When you ping your MIAB via Google or whatever, I guess you are seeing the public IP address of your router.

It is puzzling that you can access from some devices on your LAN and not others. It could be that they are looking to a different DNS to your other devices though that is unusual. If your router is providing DHCP they are possibly picking up the config from there and using the ISPs DNS

I think you said that your Mac is the ‘brains’. Does that mean it is providing some network services? Did you, for example, use Mac OS Server for email prior to MIAB?

What I’d suggest to troubleshoot is to try accessing MIAB via its LAN address from one of your windows computers. Something like the following in the browser with the relevant IP address:

If you can access webmail this way then it is an addressing issue. This can likely be fixed by adding server details on the router or changing the configuration of the Windows machines.

Hello. Sorry for answering that late. Busy day.
Thanks a lot for the advice and directions. Very much apreciated.
Please, could you elaborate a little bite your statement:
" This can likely be fixed by adding server details on the router or changing the configuration of the Windows machines" - exactly which configuration shoud I be watching over in order to change (please don’t get upset by my request - I am more than a newbie in all this field of dns’s and internet settings, router settings related to dns and stuff like this).
Thanks a lot for your help. Fantastic idea to try accessing by ip (why haven’t I thought of it? - newbie, jeje). Will try it tomorrow, because right now it’s extremely late.
I’ll keep you informed with the results.

HI. just checked accessing using the IP. It works. I could access my mailbox without any problem (from my wife’s computer, running a Windows 10 OS).
So, the reasonable question would be, now, how exactly could I solve the addressing issue, that you mentioned - which is proved, following your advice (on the other hand I honestly do not quite understand it)?
But, thanks for the advice and help.

OK that is good.

Bear in mind that installing MIAB at home is an unsupported configuration. It can be made to work however. I assume this is a bit of an experiment/learning exercise for you.

If you can access your MIAB on the LAN using the local IP address that likely means the Windows machines are getting addresses from your router (provided by your ISP?)

What you can try is to add a route for the MIAB server in your router’s DNS table. It is usually quite simple to do. You will want to add something like:

Obviously with the relevant address and local IP for your MIAB

The Windows machines on the LAN should then get the correct address from the router’s table; this will be the local IP address of your server. At the moment they probably receive the address from your ISP’s DNS and get the pubic IP address of your router and fail to connect.

Unfortunately, this change might make your box inaccessible from outside of the LAN. Router configurations can be tricky. If this is the case you can reverse what you’ve done and make a change to the config in Windows.

For further reading on the topic the following key words are worth a look.

NAT - Network Address Translation
DHCP - Dyanmic Host Configuration Protocol

Hope this helps.

I tend to think that the only aspect of MiaB not supporting local server is just the public IP address of the box is always reported incorrectly when assigned a private IP address. Otherwise, the server is just making a bunch of assumptions about the network configuration that will have to be configured locally vs. being performed by ISP.

1 Like

Another alternative perhaps, would be to add the entry to the hosts file on each of the two PC’s having issues … @danp

1 Like

Hello everybody.
Thanks a lot to all of you for your advices. I am documenting right now about how to add in my router the dns routes and stuf (and yes, it’s my ISP’s router - never worried about buying a different one - is it worth it??).
And yes, @latinhypercube, in the beggining I started the project of miab with the intention of learning about mail servers in order to have mine working. But along the way I found that I really like the miab as a program, as a “proposal” so I stopped searching other solutions, and decided to stick with this one (plus, may I reiterate that I am just an amateur IT fan, not a proffessional IT working guy - one more reason to ask for help, and so glad to have received from you).
These following days I will keep you all informed with my progress, and hopefully with a solution to this little problem (I’m sure on will come up).
And, last but not least, @openletter - I honestly have to say that I don’t fully understand all this intricate resolving addresses issues when it comes to internet. I may make assumptions about what you told me, but I really can’t get to the real meaning of the whole problematic (due to the still learning process I’m in, of course).
But gentelmen, much obliged for your help and words, and really greateful for all the time you dedicate it.
And also, @alento - I will try your suggestion too, once I read a bit more about the router mys ISP gave me. Of course I will, rest assured - I just need to learn more about the router and what my ISP lets me do with it…

Ok! But my suggestion won’t involve your router, so it is the easiest to implement, IMHO.

Even better then. I kind of got scared reading and searching the internet for information… so many things I shoul know - every article sends me to search more and more… so I got lost a bit in that amount of info. Must find specific info - but it’s not that easy at the beggining…
I turn on my wife’s computer and start digging… jejejej

Just a heads up, you may have to use the local IP rather than the internet IP … so if one does not work, try the other.

Well, maybe I have to try with the public Ip. After fighting with windows 10 to let me write in the hosts file, added at the end of it this: #dan’s mailserver

When tried to acces form the browser just didn’t charge the page. So I changed and put in the line: #dan’s mailserver
but got the same result.
So I’ll go on and try the public ip. curious fact: ping gives me a good result though…

You mean or I hope?

no, I mean:, or, without the box. in front of it…shoul I put it in hosts? #dan’s mailserver
(would this be the correct syntax for the hosts file??)

Uhmm … we got some serious DNS issues here. It is going on 1AM so I cannot help you troubleshoot yet tonight, but would be willing to tomorrow if you’d hop on to Slack.

When I check WHOIS on your IP address I am getting GoDaddy – I have never heard of GoDaddy VPS’s … and when I visit your site I am directed to a completely different site.

@alento… you just light up my brains:
I introduced #dan’s mailserver
in the hosts file. Then accessed the browser: and boom, it just led me to my log page. I am thrilled and dazzeld at the same time. Man, why is it so complicated???jajajajja
Apparently thanks to your help I made it work.
On the other hand, today I just achieved installing ubuntu server 18.04.5 on an sd for a raspberry pi. So, maybe in a future I’l give it a try and try to install miab on a raspberry. But I am taking the success of windows now. jajajajja
Thanks a milion times for the help.

1 Like