Z-push Installation Error


#1

Im having this error:

Updating system packages...
Installing system packages...
Initializing system random number generator...
Firewall is active and enabled on system startup
Installing nsd (DNS server)...
Installing Postfix (SMTP server)...
Installing Dovecot (IMAP server)...
Installing OpenDKIM/OpenDMARC...
Installing SpamAssassin...
Removing apache...
Installing Nginx (web server)...
Installing Roundcube (webmail)...
Installing Nextcloud (contacts/calendar)...
Nextcloud is already latest version
Installing Z-Push (Exchange/ActiveSync server)...
sha1sum: WARNING: 1 computed checksum did NOT match
------------------------------------------------------------
Download of http://download.z-push.org/final/2.3/z-push-2.3.8.tar.gz did not match expected checksum.
Found:
66b1613faef61590836682ff1a43d559827fe08b  /tmp/z-push.tar.gz

Expected:
aae5093212ac0b7d8bf2d79fd5b87ca5bbf091cb  /tmp/z-push.tar.gz

Anyone knows how to solve it?


#2

Please use the forum search next time friend :slight_smile:


#3

As a quick fix. Locate the file zpush.sh in the mail in a box setup folder and replace the TARGETHASH= value with 66b1613faef61590836682ff1a43d559827fe08b

This will allow it to install (if on Ubuntu please disable and remove apparmor also)

Kind regards

Geraint


#4

@g3raint Thanks, this worked for me on an existing installation. Sure beats a dist-upgrade.