Why does my dns keep breaking and now I'm consistently running into http retcodes when submitting things

Ok, let’s try some stuff in order of complexity :wink:

  1. First check if you can delete the Wiki entry from the custom dns page on the admin page.

If that does not work

  1. Make a backup of /home/user-data/dns/custom.yaml
  2. The issue might be the capital W in Wiki, so edit custom.yaml and make it lower case.
  3. Then try if you can create a new custom dns entry

If that does not work

  1. Delete the Wiki entry from custom.yaml
    This should look something like
  CNAME: fansdb.xyz.
  1. Try if you can make a new custom dns entry.

I am able to do some of this stuff direct through the panel fine it just throws that 500 every time and I have to refresh the page but it works.

Well, I did some testing as well, and the capital W does not seem to be an issue.
Do you still get the 500 after the entry is gone?

Oh, wait, you say the _dmarc line is number 22? That’s kinda crazy as that’s a default entry for Mail-in-a-Box, meaning everyone has that line, without issue.

Let’s make sure we’re looking at the right thing. Did you succeed in reconstructing the ldns-signzone command?

I have this domain using an external email service but I’ll nuke those details too for good measure.

Okay so removing the dkim dmarc and so on from the fansdb url seems to have worked which is strange because they weren’t new records. But that is fixed.

Not entirely sure what you did, but the 500 error is gone?

there was a number of third party txt records for an external email server that worked with a non standard smtp port one app we deploy needed.

For the moment I just deleted those additional email records.