Possible way to disable Greylisting

From the posts I’ve seen, there is no way to ‘disable’ Greylisting. Is there a way by chance we can have an option to do that? I understand if it’s to difficult. it’s just incredibly annoying having to wait hours for an email, especially when you’re trying to run a business.
Thanks,
Arni

Add

/.*/

to the bottom of

/etc/postgrey/whitelist_clients

(taken from here)

The latest version has a nice improvement to greylisting and then next version (in a month or so) will have an even better improvement. :slight_smile:

Yeah, I tried that. Still doesn’t work :frowning:

Oh awesome, I just restarted the server will it auto-update? Or will I need to do it manually? Also thanks for the great work and quick reply!

Updates are manual (but easy). Follow @Mailinabox on twitter for announcements.

Thanks!

I’ve had perpetual problems with greylisting. Not only do emails arrive late, many don’t arrive at all thanks to mailservers that don’t retry correctly. I’ve noticed many mailservers will retry almost immediately after the initial failure, several times in a row, before simply giving up.

Rather than disabling greylisting altogether, I’ve set the delay very low, to 1 second. Since most spammers don’t bother retrying at all, 1 second is enough to get rid of most spam, but is enough for legitimate mailservers which are simply not configured correctly.

To reduce the delay to 1 second, modify /etc/default/postgrey and change the postgrey options to read as follows:

POSTGREY_OPTS="--inet=127.0.0.1:10023 --delay=1"

You’ll need to restart postgrey after making this change:

service postgrey restart

Note that this is considered a hack, and may be overwritten by future updates to Mailinabox.

1 Like