.OVH domain set-up

Has anyone over here got experience with setting up .OVH with MIAB?

Tutorial here
https://mailinabox.email/guide.html#domain-name-registration
does not list it at all, and I am having trouble setting it up.

Glue” records set as:
ns2.box.domain.ovh [“123.123.123.123”,“2001:abc:10ab:a1233:1234:1abc:fefe:abcd”]
ns1.box.domain.ovh [“123.123.123.123”,“2001:abc:10ab:a1233:1234:1abc:fefe:abcd”]

Once set, msg come up:
Important - after validation, you must modify your DNS zone by adding:
an A record for an IPv4 address,
and an AAAA field for anIPv6 address.
You must do this for your glue record to function.

So I set “DNS servers” as:
ns1.box.domain.ovh as 2001:abc:10ab:a1233:1234:1abc:fefe:abcd
ns2.box.domain.ovh as 123.123.123.123

And lastly set the “DNS zone” as:
domain.ovh. 0 A 123.123.123.123
domain.ovh. 0 AAAA 2001:abc:10ab:a1233:1234:1abc:fefe:abcd

Now msg. come up:
Our systems have detected errors while checking your zone. The latest amendments were therefore not taken into account . To remedy this, please correct the following problems:
1. zone domain.ovh/IN: has no NS records

So what am I doing wrong?

Not using .ovh domain I can only speculate, but there are fundamental errors in what you wrote so …

would all be incorrect. You, with a NORMAL registrar, would set the glue records and then the MiaB would handle the rest. I suspect that ovh is looking at the name server from the glue records - and they do not exist as you have not installed MiaB yet …

So complete installation of MiaB, then go back and add the glue records. Remove the other stuff in the mean time.

I am just winging it with this guess. I hope that I am on the right track.

According to manual:
https://mailinabox.email/guide.html#glue-records

there is 2 parts I quote
“We’ll now go back to your domain name registrar to associate your domain name with your box’s IP address. This has two parts: glue records and nameservers.”

But OVH does not have NAMESARVERS option …

Then what are you referring to as “DNS servers” … maybe an image would be helpful?

I can help you on Slack where you can easily privately upload screenshots.

Well what is puzzling is that after setting up GLUE records this msg. come up:
Important - after validation, you must modify your DNS zone by adding:

an A record for an IPv4 address,
and an AAAA field for anIPv6 address.

You must do this for your glue record to function.

Thank you for the offer of help via Slack, but I do not use it.
I have reset the “DNS zone” and created the A,AAAA records for domain.ovh., will have to wait 24h to see what happens then I will install MIAB on the machine …

Ok, but it takes all of 2 minutes to sign up for MiaB’s slack channel …

I suspect that is not going to work … because where is that zone being hosted? No, what I think is happening is that ovh domains may want to verify the name server’s existance - and that will never happen the way you are going about it as the name server will not exist until AFTER you install MiaB.

This validates my theory - you must set up MiaB before you can create the glue records @box .

Not sure if this helps your situation but…

My miab runs on an ovh VPS. My domain is registered at namecheap.

The namecheap nameservers are set to ‘custom DNS’ with these values
ns1.box.mydomain.com
ns2.box.mydomain.com

Different situation @tkforbes. The OP is using a .ovh domain name. This TLD is one which is ran by OVH itself.

The issue here is that the .ovh domain requires name servers to be in place when setting glue records so that they can be confirmed before the name servers are accepted for the domain. So the OP needs to set aside the MiaB instructions, and do things out of order to be able to use an .ovh domain due to the restrictions of the TLD.

I have just installed MIAB and all is working
(I will wait with generating TLS (SSL) certificate and creating domain’s DNSSEC DS record)
as the DNS is still propagating according to the OVH Control Pannel and may take 48h.

Glue ” records set as:
ns2.box.domain.ovh [“123.123.123.123”,“2001:abc:10ab:a1233:1234:1abc:fefe:abcd”]
ns1.box.domain.ovh [“123.123.123.123”,“2001:abc:10ab:a1233:1234:1abc:fefe:abcd”]

DNS servers ” set as:
ns1.box.domain.ovh as 2001:abc:10ab:a1233:1234:1abc:fefe:abcd
ns2.box.domain.ovh as 123.123.123.123

DNS zone ” set as:
domain.ovh. 0 A 123.123.123.123
domain.ovh. 0 AAAA 2001:abc:10ab:a1233:1234:1abc:fefe:abcd

Lets see what will happen after 48h …

1 Like

This section at OVH really does not make much sense to me…

So if using cloudflare’s DNS (as an example) you need to provide their IP addresses? Or does this entry screen accept entries without listing the “IP associated”? The reason this is concerning is that in actuality BOTH (sic) name servers are serving answers on both IPv4 and IPv6.

I will be interested in seeing the result in 24-48 hours, and if you’d be so kind OP, would you share your domain name privately, so I can look at the DNS configuration after it is active?

That is something I will look at when I have some spare time. I am running
Debian 11/sid as desktop and some apps can be tricky to install at the moment for me …
Is there a channel name to MIAB or link to joing the group on Slack?

So 22h later and all seems to be working still on the MIAB side, no error apart from the DS/TLS that I have not set yet.

OVH panel has hoever not changed.

General information

DNS zone Error has not gone away …

DNS servers - when I first set up the GLUE records, there was no IP address,
but I have since added one in and it would not let me remove it :frowning:

App?? Sorry, but I have never installed any app. I access it via my browser.

There is a link on the project’s home page.

https://mailinabox.email/slack

1 Like

You do not enter DNS zones at OVH if they are to be served by the MiaB server. At least this is how DNS is supposed to work. I do not know if OVH has some funky set up that is non-standard. Answer the questions below, and I can make a suggestion to try — but my suggestion would likely kill your DNS in a normal situation, so it would only be used if your DNS does not work at all, which I have no way of knowing based on your replies so far.

Is your MiaB accessible to the world by a third party? Have you had someone try accessing it besides yourself? Are you receiving email?

Again. my offer of checking your set up remains, but I would need to know your domain name.

I’m with OVH and .ovh, too. From what I remember, I first set up MiaB to have a configured DNS. Also set up GLUE and A-records and in the end, a custom DNS-server. Besides DNSSEC I didn’t touch anything else.



As you can see, I kept the original NS records configured, they’re not used anyway. Since taking the screenshot, I exchanged the ns2. A record with an AAAA record for ns1. Better put those NS records back into OVH’s zone.

From what I’ve read, you’ve configured IPs for your DNS servers. You don’t need to do that, just put the ns1.box and ns2.box domains there.

Note that I replaced ns2 with a real, secondary nameserver running on another server.

Thank you,

I am still waiting for the DNS to reset do default so I can start again …(I have by mistake activated Secured Delegation - DNSSEC, but that is done in MIAB …

If you want to use DNSSEC, you have to enable it at OVH and add the data shown in your MIAB under “DS Records”.

You could try to create the two NS entries in the DNS Zone manually. There should be a yellow box like on my screenshot.

1 Like

I would, if I could :wink:

OVH has terrible customer support :frowning:

I have decided to use domain.name instead box.domain.name, so waiting for GLUE records to delete as well as DNS Servers ns1.box and ns2.box :frowning:

I wouldn’t recommend using a non-standard setup, you’re just inviting more problems to happen. I can still try my best to help you. How does your DNS Zone currently look like?

About OVH: they’re cheap, they’re reliable and they don’t help you with any questions regarding administration.

Edit: Since it says there’s an operation in progress - is that the one from days ago? What does the “Ongoing operations”-page say? If it’s an old task, you could try cancelling it (or execute it immediately if it’s possible).

I wholeheartedly agree! @box

Running MiaB without a hostname will indeed introduce other issues for you to solve.