Nextcloud version 16.0.6... checksum did NOT match

Hi, I started upgrading from 46 (i think) to 57a. Followed the instructions here:

Getting this message when updating:

Mail-in-a-Box Version:  v57a

Updating system packages...
Installing system packages...
Initializing system random number generator...
Firewall is active and enabled on system startup
Installing nsd (DNS server)...
Installing Postfix (SMTP server)...
Installing Dovecot (IMAP server)...
Installing OpenDKIM/OpenDMARC...
Installing SpamAssassin...
Installing Nginx (web server)...
Installing Roundcube (webmail)...
Installing Nextcloud (contacts/calendar)...
Upgrading Nextcloud --- backing up existing installation, configuration, and database to directory to /home/user-data/owncloud-backup/2022-08-30-00:00:56...

Upgrading to Nextcloud version 16.0.6

sha1sum: WARNING: 1 computed checksum did NOT match
Download of did not match expected checksum.
d5d25f1c855186e7e58c4b4074ca5d696343f197  /tmp/contacts.tgz

e55d0357c6785d3b1f3b5f21780cb6d41d32443a  /tmp/contacts.tgz

I have apt update, upgrade, clean, upgrade dist and rebooted (multiple times).

Tested setting version too ( with tag in setup file) to 57. I am getting the same error.

Is this something local for me that I should look into? Or should I post it on Github?

Any workarounds to get the upgrade to finish?

Thank you again for the great software🙇‍♂️

There is an issue with upgrading from very old versions of MiaB that has to do with Nextcloud. First try searching for issues here and especially GitHub.

Resolved by updating checksums in setup/ - 195*

Specifically, i had to update here for multiple versions:

		if [[ ${CURRENT_NEXTCLOUD_VER} =~ ^15 ]]; then
                        InstallNextcloud 16.0.6 0bb3098455ec89f5af77a652aad553ad40a88819 3.3.0 d5d25f1c855186e7e58c4b4074ca5d696343f197 2.0.3 a1f3835c752929e3598eb94f22300516867ac6ab 0.7.0 555a94811daaf5bdd336c5e48a78aa8567b86437
	        if [[ ${CURRENT_NEXTCLOUD_VER} =~ ^16 ]]; then
                        InstallNextcloud 17.0.6 50b98d2c2f18510b9530e558ced9ab51eb4f11b0 3.3.0 d5d25f1c855186e7e58c4b4074ca5d696343f197 2.0.3 a1f3835c752929e3598eb94f22300516867ac6ab 0.7.0 555a94811daaf5bdd336c5e48a78aa8567b86437

Working as expected now ( I think :relieved:)

1 Like

@robertosnap - this just happened to me. How exactly did you resolve? After editing the script, what ought I do? Run “sudo setup/” ? Rerun the entire upgrade ? Reboot? Something else?


FWIW - I was a bit impatient, so went ahead and ran sudo setup/ after fixing the checksums in script as @robertosnap suggested. Seems to have worked fine!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.