Mobilconfig for macOS works for initially but does not sync back


Howdy. I’m pulling my hair out, trying to get my Mac’s synchronized (and stay synchronized) with the contacts in MAIB’s Nextcloud. I really like Apple’s as a mail client, which means I am dependent on as an address book. I have found, at least since v.0.22 I think, that the contacts in MAIB show up in upon an initial setup when using the nifty mobilconfig file provided by MAIB, but after that, there is no synchronization (that I can detect).

All appears to be working great with my MAIB/Nextcloud contacts including 2-way synchronization from the CardBook plugin for Thunderbird Mail on Linux and macOS – it’s just the on macOS that is being stubborn.

I’ve tried manually configuring the CardDAV connection and reading up on Nextcloud’s documentation and troubleshooting pages – as of yet with no joy.

Has anyone made on macOS work properly for 2-way synchronization with MAIB’s Nextcloud?

I am happy to post screenshots or plist files or whatever might be helpful, but I am not sure where to start. Thanks for any input!


Hi there,

delete the account from Contacts and add a new one, choose CardDav as the type and “Manual” and then give it this URL as the server address:

Replace with your hostname and USERNAME with the mail address of the account you want to use.

With this setup it is working for me in both Sierra as well as High Sierra.

If sync still doesn’t work with this setup, it suggests that you have a contact in your list that creates problems for You’d have to find out which one it is and fix it.


Thanks hachre. I took the steps you said. Nothing was synching at all upon the initial set-up with your method. So I started with the mobilconfig file again and re-initialized a new account to make sure that still works. Added a new contact via to see if that would make it over to Nextcloud, and … no joy. :confounded:

If there really is one particular contact in my list that is messing up the synchronization for, any idea on how I could isolate it?

I mean, I’m certain I could add each of my contacts into Nextcloud one-by-one and see if it syncs over to until I find one that breaks it. But if there is a sync log I can analyze instead to find the culprit, I’d rather do that, natch. Where should I look? Server-side or client-side?


Not that I know of. I’d try to move contacts in in batches of like 5% each and see where it stops, then narrow down which one it is. I never had to do anything with the mobileconfig file for macOS.

Another thing to try is to create a new user account on your macOS and try to set it up with my method in the new account right away (no mobileconfig stuff) to see if maybe somehow your account is messed up.


That was a really good idea, and I wish I had thought of that myself. But still, no joy with your instructions.

I’m going to try to mobileconfig file setup from this secondary user on macOS to see if the behavior with that is any different.



as the sync address. I took this from my phone where it is set up slightly different. No clue if will make a difference.


Sadly, no difference I can see.

I’m thinking I’ll set up a different MAIB+Nextcloud user, put some contacts in there one-by-one, and see how that goes.


I think that’s the best course of action at this point, yeah… Good luck :slight_smile:


this works for me:

Server Path: /cloud/remote.php/dav/principals/users/


Some cautious optimism here!

I created a new MIAB + Nextcloud account and created some contacts manually. The changes are synchronizing between macOS High Sierra and Nextcloud now!

So what’s the difference between these two MAIB accounts? I can think of 3 possibilities:

  1. MIAB username format. The not-working one is like x@domain.tld and the working one is like xxxxx@domain.tld – could be rejecting a username with a single letter before the at-symbol in the email address?

  2. MIAB password. The not-working one is 19 characters long, 0-9A-Za-z and something simple for punctuation like a minus character in there. The working one has many more punctuation characters, but is only 16 characters long. Could be rejecting a 19-character password?

  3. Some contact record in my contacts really is causing a catastrophic synchronization error for

No. 1 and No. 2 above seem unlikely to me. I’m going to try a bulk import of my contacts from the non-working account to see if I get failures again.

Thanks for all the troublehooting ideas!


My best guess is #3 as well. Good luck finding the “broken” contact :slight_smile: