Gmail hates me now

Hi all,
first post.
Trying mail-in-a-box and trying to get it to work. I’ve followed the docs as carefully as I could.
All worked great for about a week and then emails to gmail not only don’t go to gmail spam, they get bounced back. Now this is happening to lots of sent mails to all other domains I send to. Basically I can’t send email to anyone. Lots of “Connection timed out”. Seems I’m receiving ok. But this worked great for a week.

My setup is on AWS (Amazon web services). Stock standard Ubuntu server 18. Then I updated/patched it all. Then loaded MIAB. All pretty standard. I have all the ports open that are required. however System Status Checks report :heavy_multiplication_x: Incoming Mail (SMTP/postfix) is running but is not publicly accessible at

mxtoolbox(dot)com reports my two domains, goodlets(dot)com and icafe(dot)com(dot)au are all good. No blacklist. I’ve even tried to get into the gmail postmaster tools page (postmaster(dot)google(dot)com/u/0/managedomains) and get the txt record which i’ve added to my dns records, still nothing. I can’t figure out why gmail and now lots of other domains are simply rejecting my email. I’ve put every recommended dns record in there.

mxtoolbox(dot)com check on my ip reports all good and even reports Connecting to… 220 box(dot)goodlets(dot)com ESMTP Hi, I’m a Mail-in-a-Box (Ubuntu/Postfix; see https:// mailinabox(dot)email/) [1819 ms]

What am I doing wrong or how do I troubleshoot this further? I don’t know what else to do?
Thanks in advance.
(i’ve put (dot) in place of .)

Welcome to the “Gmail hates me” club @Bendo You are in good company.

I think that I see a couple of possible issues but at the moment I don’t have time to troubleshoot for you. I will get back with you later today.

Have you contacted AWS and requested them to unblock port 25 so that you can run an email server? AWS requires this. @Bendo

The second issue - and this is absolutely the big issue. You have NOT requested AWS to set the rDNS (PTR record) for your MiaB instance. I am showing that it is:

but needs to be

The third issue is that you’re trying to run a mail server on AWS … their IP ranges are blocked by many because of spammers. I am working with someone else right now to find a solution … and it looks like that solution may be an inexpensive SMTP relay that I have developed OR simply not using AWS for MiaB installations.

Search here for pupsncats. He has a tutorial for MiaB on AWS Lightsail.