Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: Connection refused

Hello everyone,

I am just trying to install mailinabox on a fresh install and it seems I can’t get over this problem ( Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: Connection refused )

Any help is much appreciated

Please provide more details about the machine you set up.

Hi JoshData let me know what info you need.
It’s an Ubuntu 14.04.3 LTS VPS with 1GB RAM fresh installation.

What cloud host provider? I don’t know what the problem is – I might have to be able to reproduce it to see.

It’s time4vps if you like I can provide you with a test box, just let me know

Found it!!!
Dovecot was listening to IPv6 while I didn’t have IPv6 routed to this box.

Were you able to get it working?

I am almost there, I need to disable IPv6 on nginx now which seems to be more tricky than I thought.
Problem is none of the IPv6 disable tricks on ubuntu work so far and I can’t add IPv6 on this box at the moment.

Fixed everything!!!

System Status Checks

✓All system services are running.

Can you post a list of changes you made?

Yes I will, getting that ready and will post in a while


  1. Ubuntu 14.04 fresh installation
  2. Minifi the installation
  3. apt-get update
  4. apt-get install curl
  5. apt-get install sudo
  6. curl -s | sudo bash

First error message after the initial questions about the email address and the hostname

  • FAILED: service postgrey restart
  • Solution : Manually restart postgrey and run again

Second error

Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: Connection refused
doveadm( Fatal: User lookup failed: Internal error occurred. Refer to server log for more information.

Solution: This is actually a problem when your box doesn’t have Ipv6 enabled but your Kernel and your settings do… and here’s the problem, on ubuntu I wasn’t able to actually disable Ipv6 …maybe you are more luck than I was, besides ubuntu is not my most favorite distro.

So edit /etc/dovecot/dovecot.conf and find the line
#listen = *, ::
and change it to
listen = *

You can test dovecot now with service dovecot restart, you will see that dovecot wasn’t running but now it started…

So let’s do the process again… running curl and

This time your installation finishes all the way and you can actually add the new email, which in our case is the admin emai…
But …yes there’s a but, nginx refuses to start… so here’s what you need to do in order to have nginx start… you need to disable nginx Ipv6 functionality.

Here’s how you can achieve this ….

First locate /etc/nginx/conf.d/local.conf and comment the following lines
listen [::]:80;
You need to do this in server section and https section…
Second find the /etc/sites-available/default file and edit the Ipv6 lines again

Now you can start nginx!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Thanks for posting this.