Emails to hotmail go directly to junk folder


#1

Hi,
All emails from miab to hotmail arrive in the junk folder even after marking them as not junk in hotmail.

I want to test the mailgun free service to bypass my issue.
They say:
We recommend using a subdomain with Mailgun, like “ mg.mydomain.com ”. Using a subdomain you will still be able to send emails from your root domain e.g. “ you@mydomain.com ”.

If using a subdomain please make sure that you configure MX records for the subdomain for optimal delivery.

Can I just use box.mydomain.com as subdomain without anymore mx records configuration?

Thanks!


#2

This has been talked about multiple times, you will need to contact Microsoft to resolve that issue. I think you will find the following link helpful: http://postmaster.live.com/

But next time, search the forums before posting. :slight_smile: good luck!


#3

Yes, I forgot to say that I contacted them in the past with no luck. That’s why I want to try mailgun.


#4

So, can I use box.mydomain.com as subdomain?


#5

I decided to use mg.mydomain.com as subdomain for mailgun purposes.

Can someone tell me how to properly add mx records under custom dns.
I need to add an mx record with priority 10 and value=mxa.mailgun.org

Is it Name=mg.mydomain.com
and
Value=10 mxa.mailgun.org. (including the trailing dot)

Thanks!


#6

Uhmm, what are you trying to do here?

I think that you want to be relaying your outgoing mail through MailGun … if that is the case you do not need to be setting up a MX record as MX records are for incoming mail.

Judging from the records that you asked about … maybe you are doing something different? Where does the mxa.mailgun.org come from and why are you setting up anything for it?

From https://www.mailgun.com/smtp

SMTP Relay

Using an SMTP relay service is the simplest way to get started sending emails. Add and verify your domain name, choose between a dedicated or shared IP address, and then set up your SMTP server. You only need four pieces of information: your username, password, the SMTP server host name, and the SMTP port. Add these into your application’s SMTP configuration settings, and you’re ready to send with Mailgun. Depending on which port you use, you can have either a regular or SSL connection to add security to your email.

None of this has to do with DNS records … you will need to modify your MiaB’s Postfix config files by adding the information referenced above. The information will be provided by Mailgun. See the below link for instructions on how to set this up. Make sure that you click the Linode link in that post for the instructions.


#7

Alento, thanks for the input. I know you know what you’re talking about. I’m just following instructions from mailgun support.
If that doesn’t work I think I’ll ask digital ocean to give me a reputable IP.


#8

And I am just trying to save you the frustration of going down that rabbit hole. Support is on a different page than you and I are.

Check your IP here: https://www.talosintelligence.com/ as you do not necessarily have an IP issue … rather you have a Micro$oft issue.


#9

You are correct. I just checked and my reputation is neutral so, damn MSFT.


closed #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.