Apple Mail doesn't work with archiving mail

I’ve had mailinabox working for about a month or two now. I’ve got archives enabled and Roundcube works fine with it but I’ve found when I move or archive a email from Applemail it gets deleted from the inbox and a “duplicate” shows up in the other folder I’ve moved/archived it to.

did you create an “archive” folder in round cube? I also use apple mail app and I have to create a few folders, one archive, and I think sent. Also, once I did those on the round cube side, I had to use the spam folder as “junk” by clicking the “Spam” folder on apple mail (where it pulled that folder in from my and then click on in the menu: Mailbox, then “use this mailbox as” ‘Junk’ — after that all of them via imap synced to the right boxes… I think for yours you won’t even have to do this with the “archive” folder, just create it on round cube first, then it should work (only reason Junk/Spam didn’t is because the names are different, and yes I tried to name it “junk” on round cube, but then spam assasain is programmed to put it in “spam” so that didn’t work either. Anyway, just create the Archvie folder on round cube, then in settings special folders area mark it to use that mailbox as Archive, it should work of for you, that is all I did and it works for me.

Attached is screen capture of how I have mine, and they match up (except for Spam/Junk like I said above) with apple mail just fine for me:

Archiving works from roundcube so I don’t think it’s related to what you’re saying. I already have an archive folder and it works fine from roundcube, so does moving emails. What doesn’t work is moving/archiving emails from within the OSX mail app.

When I archive or move emails using the mail app I end up with the email in my archive folder and then an email like this in the inbox. I can even delete this email and it’ll remain in the archive folder as well. It seems to be duplicating or copying the email instead of moving it.

I can’t link to the image as I just made my account.

Okay and on the OS X side do you see the Archive folder by itself? (like at the bottom) or is it up there with your iCloud folders? (I’m assuming you have an iCloud folder) – If it is by itself, that means the imap mapping is not working between the two and you can click on the Archive folder on the mac, and then do like Is said above where you can “assign” it to archive. I"m also assuming you’re on either yosemetie or el captain beta - those both work 100% for me and mailinthe box (all folders but Junk/Spam, even archive works out of the box)---- but if you’r folder is not under the archive “area” assigning it like I said above for the junk spam folder should fix it. The imgurl is u6T2snY.png At then slash then u6T2snY.png that is on the round cube side though, and you already have it setup so that like you said is probably not it.

Edit: Okay I made a new one of how it shows on my OS X mail or qNZXjnf after you goto imgur . com

Looks like I can add images now. I actually don’t use any iCloud services so I only have my maininthebox account added to OSX(Yosemite), this is what my mail app looks like. I made sure to go through each one and select, then make sure it lines up with the correct one under “use this mailbox as…”

Well I’m not sure what else to try, I know I get weirdness all the time, and especially when I use OS X mail app on google domain mail or fast mail etc. but I would suggest you delete that account, and re-add it. Since you have it setup on the back end ( and that is working, not sure what else other than purge the old one out and try adding it in again, that has worked for me before, and I hope it works for you, but I know it’s a long shot. Maybe others can add in who may have had similar experienced and fixed it. I’m pretty sure Josh doesn’t use apple mail, but I’m sure others on here do and hopefully will have a better idea.

I tired pretty much everything I could think of, I even went so far as to install OSX on another HDD and try from a fresh instal and still nothing. :frowning: Guess I’m stuck using RoundCube to archive mail for now. Thanks.

I’ve worked this out, when you archive mail using apple mail it shows as deleted for about 5 minutes and then disappears from there. I’m assuming it’s something todo with the archive timeout.

Continuing the discussion from Apple Mail doesn't work with archiving mail:

Mine doesn’t do this, I have a fresh install now too, it didn’t do it on v.0.12, and not on v.13, and not on v.13a with my apple mail app — if I have a new item, and it unread, I click on archive, it will send it to archive folder and mark it as read instantly (no delays) - same if I were to delete it. I also tried this on the web site (round cube) and the results were the same, and (almost) instantly replicated on the client on the desktop. Maybe it has something to do with your imap mapping settings somewhere, but I think we checked those already.